TEAM COTTON'S PERFORMANCE TURBO BUICK ONLINE FORUMS  

Go Back   TEAM COTTON'S PERFORMANCE TURBO BUICK ONLINE FORUMS > Technical Forums > Transmissions and Torque Converters

Transmissions and Torque Converters Tranny and torque converter tech support

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 06-05-2008, 02:36 AM
Chris Garrett Chris Garrett is offline
Junior Member
 
Join Date: Nov 2007
Posts: 6
Default No Traction

Hi guys,
If I go more than 1/2 throttle, I can't get any traction. The tires spin and the backend fishtails out of control. I have MT street radials. I have kept them at 35 psi which I think is part of my problem. They have about 4-5k miles on them.
My question is could my torque converter be causing this? I have a Vigilanti 3200-3400. My mods are listed below.

2008 rebuild, Comp roller cam, Cat stroker, RJC gridle, CPT66BB, PTE Stock Location IC, Champion iron, T&D roller rockers, 60# Mototron injectors w/Turbotweak chip, Monroe-ported throttlebody, RJC Power Plate, Jimmy-built trans w/Precision Vigilante converter, ATR SS dual exhaust, ATR rear sway, BMR upper and lower control arms, Edelbrock Performance shocks, Razor alky, Tinman cold air intake, MT street radials.
Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:30 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.